CISCO 2 провайдера

Вводные данные:

ISP1: 1.1.1.2/30 GW 1.1.1.1 int GigabitEthernet0/0

ISP2: 2.1.1.2/30 GW 2.1.1.1 int GigabitEthernet0/1

LAN: 192.168.0.0/24 int GigabitEthernet0/2

Поехали:

ip sla 100
 icmp-echo 8.8.8.8 source-interface GigabitEthernet0/0
 threshold 1000
 frequency 10
ip sla schedule 100 life forever start-time now
!
ip sla 101
 icmp-echo 8.8.4.4 source-interface GigabitEthernet0/1
 threshold 1000
 frequency 10
ip sla schedule 101 life forever start-time now
!

track 100 ip sla 100 reachability
 delay down 5 up 5
!
track 101 ip sla 101 reachability
 delay down 5 up 5
! 
interface GigabitEthernet0/0 
ip address 1.1.1.2 255.255.255.252
no shut
ip nat outside 
! 
interface GigabitEthernet0/1 
ip address 2.1.1.2 255.255.255.252
no shut
ip nat outside 
! 
interface GigabitEthernet0/2
ip address 192.168.0.1 255.255.255.0
ip nat inside 
no shut
ip policy route-map PolicyBaseRouting-nexthop 
! 
ip route 0.0.0.0 0.0.0.0 1.1.1.1 1 track 100
ip route 0.0.0.0 0.0.0.0 2.1.1.1 2 track 101
ip route 0.0.0.0 0.0.0.0 1.1.1.1  254 
! 
ip nat inside source route-map ISP_1 interface GigabitEthernet0/0 overload
ip nat inside source route-map ISP_2 interface GigabitEthernet0/1 overload
!
route-map ISP_1 permit 10
match ip address 100
match interface GigabitEthernet0/0
!
route-map ISP_2 permit 10
match ip address 100
match interface GigabitEthernet0/1
!
route-map PolicyBaseRouting-nexthop permit 10 
set ip next-hop verify-availability 1.1.1.1 1 track 100
set ip next-hop verify-availability 2.1.1.1 2 track 101
! 
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
access-list 100 deny ip any any
!
event manager applet DOWN_and_UP
 event track 100 state any
 action 1.0 cli command "clear ip nat trans forced"
!

Статья помогла? поддержите проект!

CISCO 2 провайдера: 5 комментариев

  1. Алексей

    В контексте Вашей статьи не могли бы Вы помочь?

    В данный момент понадобилось немного усложнить роутинг… Что есть и что нужно…

    Есть 2901 с допмодулем на 4 порта, старый (по земле) и новый (радио) каналы Инета и несколько вланов (привязаны к разным портам допмодуля) во внутренней сетке: один для компов, один для voIP и один для выделенного сервака (ходють туда извне все кому не лень…))).

    Кабель старого (шибко много денег жрал) канала был вынут (в начале декабря), вместо него шнурок нового (анлим за вменяемые деньги, с лучшей шириной) в тот же порт с перенастройкой. Все пользователи в щасте — мне «плюшки»…

    После праздников с телефонией начались проблемы и было принято решение VoIP вернуть в старый канал (по «земле» оно как-то надёжнее и денег немного жрёт) и тут я «встал»…гугление и «курение мануалов» привело к некоторым результатам и были внесены правки в конфу…после этого, «тормоз просто сожрал меня»…не идут пакеты от подсетки телефонии в старый канал, даже пинги не идут через него, при этом пров говорит, что какой-то трафик ходит.

    Т.е. нужно чтобы Vlan 7 и Vlan 10 ходили через g0/0, а Vlan 9 через g0/1

    Я даже все ACL упростил(фактически разрешив всё) на период настройки, чтобы ничего не резалось…но не помогает…

    Где у меня в конфе косяк?

    Current configuration : 6088 bytes
    !
    ! Last configuration change at 09:47:38 PCTime Fri Jan 16 2015 by ххххххх
    !
    version 15.5
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname al-rt
    !
    boot-start-marker
    boot system flash c2900-universalk9-mz.SPA.155-1.T.bin
    boot-end-marker
    !
    !
    logging buffered 3200000
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
    enable password 7 xxxxxxxxxxxxxxxxx
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    !
    aaa session-id common
    bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
    clock timezone PCTime 3 0
    clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
    !
    ip dhcp excluded-address 192.168.7.201 192.168.7.254
    ip dhcp excluded-address 192.168.9.1 192.168.9.49
    ip dhcp excluded-address 192.168.9.201 192.168.9.254
    ip dhcp excluded-address 192.168.7.1 192.168.7.99
    !
    ip dhcp pool Data
    import all
    network 192.168.7.0 255.255.255.0
    default-router 192.168.7.254
    dns-server 192.168.7.254 80.76.224.2
    lease 7
    !
    ip dhcp pool VoIP
    import all
    network 192.168.9.0 255.255.255.0
    default-router 192.168.9.254
    dns-server 192.168.9.254 83.242.140.10
    lease infinite
    !
    !
    !
    ip domain name xxxxxxxx.ru
    ip name-server 8x.7x.2xx.x
    ip name-server 8x.7x.2xx.1x
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    cts logging verbose
    !
    crypto pki trustpoint xxxxxxxxxxxxxxxxxxxx
    !
    !
    crypto pki xxxxxxxxxxxxxxxxxxxxxxxxxxxx
    quit
    license udi pid CISCO2901/K9 sn xxxxxxxxxxxxxx
    license boot module c2900 technology-package securityk9
    license boot module c2900 technology-package datak9
    !
    !
    username xxxxxxxxxxx privilege 15 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    redundancy
    !
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    !
    interface GigabitEthernet0/0
    description radioWAN
    ip address 8x.7x.2xx.2xx 255.255.255.252
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description ethWAN
    ip address 2xx.2xx.7x.1xx 255.255.255.252
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    no mop enabled
    !
    interface GigabitEthernet0/1/0
    description VoIP
    switchport access vlan 9
    no ip address
    !
    interface GigabitEthernet0/1/1
    description alportal
    switchport access vlan 10
    no ip address
    !
    interface GigabitEthernet0/1/2
    description Int_WiFi
    switchport access vlan 7
    no ip address
    !
    interface GigabitEthernet0/1/3
    description al-fs2
    switchport access vlan 7
    no ip address
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan7
    ip address 192.168.7.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    interface Vlan9
    description VoIP
    ip address 192.168.9.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    interface Vlan10
    description alportal
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    !
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip flow-top-talkers
    top 20
    sort-by bytes
    cache-timeout 360000
    !
    no ip nat service sip udp port 5060
    ip nat inside source list NAT interface GigabitEthernet0/0 overload
    ip nat inside source static tcp 192.168.7.5 xxxx interface GigabitEthernet0/0 xxxx
    ip nat inside source static tcp 10.10.10.10 xxxx interface GigabitEthernet0/0 xxxx
    ip nat inside source static tcp 10.10.10.10 xxxx interface GigabitEthernet0/0 xxxx
    ip nat inside source static tcp 192.168.7.119 xxxx interface GigabitEthernet0/0 xxxx
    ip nat inside source list ethNAT interface GigabitEthernet0/1 overload
    ip route 0.0.0.0 0.0.0.0 8x.7x.2xx.2xx
    ip route 192.168.9.0 255.255.255.0 GigabitEthernet0/1 2xx.2xx.7x.1xx 10
    !
    ip access-list standard NAT
    permit 192.168.7.0 0.0.0.255
    permit 192.168.9.0 0.0.0.255
    permit 10.10.10.0 0.0.0.255
    ip access-list standard ethNAT
    permit 192.168.9.0 0.0.0.255
    deny any
    !
    ip access-list extended NAT_ethWAN
    !
    logging trap debugging
    logging host 192.168.7.5
    !
    end

  2. Андрей

    Здравствуйте!
    Я перепробовал уже множество вариантов конфигов с переключением между двумя провайдерами и вот какая проблема у меня возникает: IP SLA прекрасно отрабатывает и туда и обратно, маршруты переключаются так как нужно НО правила трансляции переключаться никак не хотят, т.е при загрузки маршрутизатора активируется первое, в вашем конфиге это «ip nat inside source route-map ISP_1 interface GigabitEthernet0/0 overload» и на этом всё — второе правило уже не включается ни при каких обстоятельствах. Если я принудительно убираю первое правило командой no, то канал тут же поднимается и все начинает работать как надо.
    Не могли бы Вы помочь с этим разобраться?

  3. Виталий

    Добрый день.
    Подскажите как сделть чтоб трафик ходил с interface GigabitEthernet0/2 на другой внутрений интерфейс, например LAN2: 192.168.1.0/24 int GigabitEthernet0/3. После применения ip policy route-map PolicyBaseRouting-nexthop на интерфейсе GigabitEthernet0/2 трафик с сети 192.168.0.0/24 в сеть 192.168.1.0/24 ходить перестает.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Time limit is exhausted. Please reload the CAPTCHA.